设为首页收藏本站

IPv6BBS

 找回密码
 注册

扫一扫,访问微社区

QQ登录

只需一步,快速开始

查看: 965|回复: 3

在GNS3上配置NAT64遇到的问题,求助各位大侠。

[复制链接]
MAQ81 发表于 2016-11-1 11:29:29 | 显示全部楼层 |阅读模式
本帖最后由 MAQ81 于 2016-11-1 11:30 编辑

一、网络拓扑和实验环境: "()"接口名称,“ [ ]” 网段标识

PC10 (e0)----[fec0:10:1::/64]----(e0/0)R1(Serial1/1)----[172.16.1.0/24]----(Serial1/1)ISP(fas0/0)----[10.3.1.0/24]----(e0/0)PC30

PC10 PC30:VPCS
R1: I86BI_LINUX-ADVENTERPRISEK9-M
ISP:C7200-JK9O3S-M

二、设备的主要配置
PC10> show
NAME   IP/MASK              GATEWAY           MAC                LPORT  RHOSTORT
PC10   0.0.0.0/0            0.0.0.0           00:50:79:66:68:00  10001  10.80.0.100:10000
       fe80::250:79ff:fe66:6800/64
       fec0:10:1:0:2050:79ff:fe66:6800/64

R1#show running-config
Building configuration...
!
hostname R1
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Ethernet0/0
no ip address
nat64 enable
ipv6 address FEC0:10:1::/64 eui-64
ipv6 enable
!
interface Serial1/1
ip address 172.16.1.1 255.255.255.0
nat64 enable
serial restart-delay 0
!
ip route 0.0.0.0 0.0.0.0 Serial1/1
!         
nat64 prefix stateful FEC0:10:3::/96
nat64 v4 pool IPV4POOL 172.16.1.11 172.16.1.12
nat64 v6v4 list MYLIST pool IPV4POOL overload
!
ipv6 access-list MYLIST
permit ipv6 FEC0:10:1::/48 any
end
R1#  

ISP#show running-config
Building configuration...
!
hostname ISP
!         
interface FastEthernet0/0
ip address 10.3.1.3 255.255.255.0
duplex half
!
interface Serial1/1
ip address 172.16.1.3 255.255.255.0
serial restart-delay 0
clock rate 64000
!
end
ISP#

PC30> show
NAME   IP/MASK              GATEWAY           MAC                LPORT  RHOSTORT
PC30   10.3.1.30/24         10.3.1.3          00:50:79:66:68:02  10005  10.80.0.100:10004
       fe80::250:79ff:fe66:6802/64

三、测试结果
1、在R1上测试到PC30的IPv4连通性
R1#ping 10.3.1.30
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.1.30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/21 ms
R1#

2.从PC10测试到PC30的IPv6连通性(结果失败,求指导)
PC10> ping fec0:10:3::a:3:1:1e (PC30        对应的NAT64地址)

fec0:10:3::a:3:1:1e icmp6_seq=1 timeout
fec0:10:3::a:3:1:1e icmp6_seq=2 timeout
fec0:10:3::a:3:1:1e icmp6_seq=3 timeout
fec0:10:3::a:3:1:1e icmp6_seq=4 timeout
fec0:10:3::a:3:1:1e icmp6_seq=5 timeout

PC10>
满天星 发表于 2016-11-1 13:37:58 | 显示全部楼层
show nat64 translations

另外,不确定模拟器是否支持,官网的说明是:

Cisco Products That Support NAT64

Cisco ASR 1000 Series          Cisco Carrier Routing System (CRS-1)
Stateless NAT64     Cisco IOS® XE 3.2S     Cisco IOS XR 3.9.3
Stateful NAT64      Cisco IOS XE 3.4S         Cisco IOS XR 4.1.2
 楼主| MAQ81 发表于 2016-11-3 09:26:50 | 显示全部楼层
配置没有什么问题吧
满天星 发表于 2016-11-3 11:27:57 | 显示全部楼层
根据官网的配置说明,理论上来说配置没啥问题了,接口enable,配置prefix和转换规则,好像就够了
您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|手机版|小黑屋|IPv6BBS ( 京ICP备13024693号 | 京公网安备11010802012238  

GMT+8, 2017-12-12 02:52 , Processed in 0.258260 second(s), 22 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表